summaryrefslogtreecommitdiff
path: root/overlays/smartprom/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/smartprom/default.nix')
-rw-r--r--overlays/smartprom/default.nix36
1 files changed, 18 insertions, 18 deletions
diff --git a/overlays/smartprom/default.nix b/overlays/smartprom/default.nix
index 807f3f84..57ab6f11 100644
--- a/overlays/smartprom/default.nix
+++ b/overlays/smartprom/default.nix
@@ -1,21 +1,21 @@
1{ final, prev, flakeInputs, sources, ... }: 1{ prev, sources, ... }:
2let 2{
3 inherit (prev.stdenv.targetPlatform) system; 3 smartprom =
4in { 4 with prev.poetry2nix;
5 smartprom = flakeInputs.mach-nix.lib.${system}.buildPythonPackage rec { 5 mkPoetryApplication {
6 inherit (sources.smartprom) src pname version; 6 inherit (sources.smartprom) pname version;
7 ignoreDataOutdated = true; 7 projectDir = cleanPythonSources {
8 src = prev.runCommand "sources" {} ''
9 mkdir $out
10 cp -r ${sources.smartprom.src}/. $out
8 11
9 prePatch = '' 12 mkdir $out/smartprom
10 mkdir smartprom 13 mv $out/smartprom.py $out/smartprom/__main__.py
11 mv smartprom.py smartprom/__main__.py 14 echo >> $out/smartprom/__init__.py
12 echo >> smartprom/__init__.py
13 15
14 substituteAll ${./setup.py} ./setup.py 16 cp ${./pyproject.toml} $out/pyproject.toml
15 ''; 17 cp ${./poetry.lock} $out/poetry.lock
16 18 '';
17 requirements = '' 19 };
18 prometheus_client 20 };
19 '';
20 };
21} 21}