summaryrefslogtreecommitdiff
path: root/overlays/postfix-mta-sts-resolver/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/postfix-mta-sts-resolver/pyproject.toml')
-rw-r--r--overlays/postfix-mta-sts-resolver/pyproject.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/overlays/postfix-mta-sts-resolver/pyproject.toml b/overlays/postfix-mta-sts-resolver/pyproject.toml
new file mode 100644
index 00000000..50957a64
--- /dev/null
+++ b/overlays/postfix-mta-sts-resolver/pyproject.toml
@@ -0,0 +1,24 @@
1[tool.poetry]
2name = "postfix_mta_sts_resolver"
3version = "1.3.0"
4authors = ["Vladislav Yarmak <vladislav-ex-src@vm-0.com>"]
5description = "Daemon which provides TLS client policy for Postfix via socketmap, according to domain MTA-STS policy"
6readme = "README.md"
7license = "MIT"
8
9[tool.poetry.scripts]
10mta-sts-daemon = "postfix_mta_sts_resolver.daemon:main"
11mta-sts-query = "postfix_mta_sts_resolver.__main__:main"
12
13[tool.poetry.dependencies]
14python = ">=3.7,<3.11.0"
15aiodns = "^3.0.0"
16aiohttp = "^3.8.4"
17PyYAML = "^6.0"
18
19redis = "^4.5.4"
20uvloop = "^0.17.0"
21
22[build-system]
23requires = ["poetry-core>=1.0.0"]
24build-backend = "poetry.core.masonry.api"