summaryrefslogtreecommitdiff
path: root/overlays/postfix-mta-sts-resolver/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/postfix-mta-sts-resolver/default.nix')
-rw-r--r--overlays/postfix-mta-sts-resolver/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/overlays/postfix-mta-sts-resolver/default.nix b/overlays/postfix-mta-sts-resolver/default.nix
new file mode 100644
index 00000000..49fbb7c9
--- /dev/null
+++ b/overlays/postfix-mta-sts-resolver/default.nix
@@ -0,0 +1,17 @@
1{ prev, sources, ... }:
2{
3 postfix-mta-sts-resolver =
4 with prev.poetry2nix;
5 mkPoetryApplication {
6 inherit (sources.postfix-mta-sts-resolver) pname version;
7 projectDir = cleanPythonSources {
8 src = prev.runCommand "sources" {} ''
9 mkdir $out
10 cp -r ${sources.postfix-mta-sts-resolver.src}/. $out
11
12 cp ${./pyproject.toml} $out/pyproject.toml
13 cp ${./poetry.lock} $out/poetry.lock
14 '';
15 };
16 };
17}