summaryrefslogtreecommitdiff
path: root/overlays/postfix-mta-sts-resolver.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/postfix-mta-sts-resolver.nix')
-rw-r--r--overlays/postfix-mta-sts-resolver.nix33
1 files changed, 0 insertions, 33 deletions
diff --git a/overlays/postfix-mta-sts-resolver.nix b/overlays/postfix-mta-sts-resolver.nix
deleted file mode 100644
index b28ac61f..00000000
--- a/overlays/postfix-mta-sts-resolver.nix
+++ /dev/null
@@ -1,33 +0,0 @@
1{ final, prev, flakeInputs, sources, ... }:
2let
3 inherit (prev.stdenv.targetPlatform) system;
4in {
5 postfix-mta-sts-resolver = flakeInputs.mach-nix.lib.${system}.buildPythonPackage {
6 inherit (sources.postfix-mta-sts-resolver) src pname version;
7 # extras = "redis,uvloop";
8 ignoreDataOutdated = true;
9
10 requirements = ''
11 redis>=4.2.0rc1
12 uvloop>=0.11.0
13 aiodns>=1.1.1
14 aiohttp>=3.4.4
15 PyYAML>=3.12
16 '';
17
18 providers.cffi = "nixpkgs";
19
20 # providers._default = "nixpkgs,sdist";
21
22 # overridesPost = [
23 # (self: super: {
24 # frozenlist = super.frozenlist.overrideAttrs (oldAttrs: {
25 # nativeBuildInputs = (oldAttrs.nativeBuildInputs or []) ++ [ final.python310Packages.cython ];
26 # });
27 # })
28 # ];
29
30 # _.pyparsing.buildInputs.add = with final.python310Packages; [ flit-core ];
31 # _.idna.buildInputs.add = with final.python310Packages; [ flit-core ];
32 };
33}