summaryrefslogtreecommitdiff
path: root/overlays/pidgin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/pidgin.nix')
-rw-r--r--overlays/pidgin.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/overlays/pidgin.nix b/overlays/pidgin.nix
new file mode 100644
index 00000000..d346c7a1
--- /dev/null
+++ b/overlays/pidgin.nix
@@ -0,0 +1,15 @@
1final: prev:
2let
3 mucHistory = prev.fetchpatch {
4 url = "https://developer.pidgin.im/raw-attachment/ticket/16524/0001-only-request-unseed-chat-history-from-jabber-group-c.patch";
5 sha256 = "083wvmq7417xz55fxxhllqwql1hgjvin2sak08844121yw1jvc44";
6 };
7in {
8 pidgin-with-plugins = import (/. + prev.path + "/pkgs/applications/networking/instant-messengers/pidgin/wrapper.nix") {
9 inherit (prev) makeWrapper symlinkJoin;
10 plugins = with final; [ purple-lurch pidgin-carbons pidgin-opensteamworks pidgin-xmpp-receipts ];
11 pidgin = prev.pidgin.overrideAttrs (oldAttrs: {
12 patches = (oldAttrs.patches or []) ++ [mucHistory];
13 });
14 };
15}