summaryrefslogtreecommitdiff
path: root/overlays/matrix-synapse/1.70.1/plugins/ldap3.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/matrix-synapse/1.70.1/plugins/ldap3.nix')
-rw-r--r--overlays/matrix-synapse/1.70.1/plugins/ldap3.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/overlays/matrix-synapse/1.70.1/plugins/ldap3.nix b/overlays/matrix-synapse/1.70.1/plugins/ldap3.nix
new file mode 100644
index 00000000..394c0f5e
--- /dev/null
+++ b/overlays/matrix-synapse/1.70.1/plugins/ldap3.nix
@@ -0,0 +1,17 @@
1{ isPy3k, buildPythonPackage, fetchPypi, service-identity, ldap3, twisted, ldaptor, mock }:
2
3buildPythonPackage rec {
4 pname = "matrix-synapse-ldap3";
5 version = "0.1.5";
6
7 src = fetchPypi {
8 inherit pname version;
9 sha256 = "9fdf8df7c8ec756642aa0fea53b31c0b2f1924f70d7f049a2090b523125456fe";
10 };
11
12 propagatedBuildInputs = [ service-identity ldap3 twisted ];
13
14 # ldaptor is not ready for py3 yet
15 doCheck = !isPy3k;
16 checkInputs = [ ldaptor mock ];
17}