diff options
Diffstat (limited to 'overlays/fast-cli.nix')
-rw-r--r-- | overlays/fast-cli.nix | 34 |
1 files changed, 0 insertions, 34 deletions
diff --git a/overlays/fast-cli.nix b/overlays/fast-cli.nix deleted file mode 100644 index a318eada..00000000 --- a/overlays/fast-cli.nix +++ /dev/null | |||
@@ -1,34 +0,0 @@ | |||
1 | { prev, sources, ... }: { | ||
2 | fast-cli = prev.buildGoModule rec { | ||
3 | pname = "fast-cli"; | ||
4 | |||
5 | inherit (sources.fast-cli) version src; | ||
6 | vendorSha256 = "sha256-XM/5kUau0JBMxN0UpX6QNI31i8/+HNFvgFUFtlJsBh0="; | ||
7 | |||
8 | preBuild = let | ||
9 | goMod = prev.writeText "go.mod" '' | ||
10 | module github.com/gesquive/fast-cli | ||
11 | |||
12 | go 1.17 | ||
13 | |||
14 | require ( | ||
15 | github.com/dustin/go-humanize v0.0.0-20170228161531-259d2a102b87 | ||
16 | github.com/fatih/color v1.4.1 | ||
17 | github.com/gesquive/cli v0.2.0 | ||
18 | github.com/inconshreveable/mousetrap v1.0.0 | ||
19 | github.com/mattn/go-colorable v0.0.8-0.20170210172801-5411d3eea597 | ||
20 | github.com/mattn/go-isatty v0.0.2-0.20170307163044-57fdcb988a5c | ||
21 | github.com/spf13/cobra v0.0.0-20170531045452-8d4ce3549a0b | ||
22 | github.com/spf13/pflag v1.0.0 | ||
23 | golang.org/x/sys v0.0.0-20170213225739-e24f485414ae | ||
24 | ) | ||
25 | ''; | ||
26 | in '' | ||
27 | install -v -m 0644 ${goMod} ./go.mod | ||
28 | ''; | ||
29 | |||
30 | ldflags = [ | ||
31 | "-X main.version=${prev.lib.removePrefix "v" version}" | ||
32 | ]; | ||
33 | }; | ||
34 | } | ||