summaryrefslogtreecommitdiff
path: root/overlays/fast-cli.nix
diff options
context:
space:
mode:
Diffstat (limited to 'overlays/fast-cli.nix')
-rw-r--r--overlays/fast-cli.nix12
1 files changed, 3 insertions, 9 deletions
diff --git a/overlays/fast-cli.nix b/overlays/fast-cli.nix
index 314d3796..932c5a38 100644
--- a/overlays/fast-cli.nix
+++ b/overlays/fast-cli.nix
@@ -1,14 +1,8 @@
1final: prev: { 1{ final, prev, sources, ... }: {
2 fast-cli = prev.buildGoModule rec { 2 fast-cli = prev.buildGoModule rec {
3 pname = "fast-cli"; 3 pname = "fast-cli";
4 version = "0.2.10";
5 4
6 src = prev.fetchFromGitHub { 5 inherit (sources.fast-cli) version src;
7 owner = "gesquive";
8 repo = pname;
9 rev = "v${version}";
10 hash = "sha256-j7/3Llc3jTeJGpOH3Aexm9qcNscuk0mbi4ZCCyzC3+s=";
11 };
12 vendorSha256 = "sha256-XM/5kUau0JBMxN0UpX6QNI31i8/+HNFvgFUFtlJsBh0="; 6 vendorSha256 = "sha256-XM/5kUau0JBMxN0UpX6QNI31i8/+HNFvgFUFtlJsBh0=";
13 7
14 preBuild = let 8 preBuild = let
@@ -34,7 +28,7 @@ final: prev: {
34 ''; 28 '';
35 29
36 ldflags = [ 30 ldflags = [
37 "-X main.version=${version}" 31 "-X main.version=${prev.lib.removePrefix "v" version}"
38 ]; 32 ];
39 }; 33 };
40} 34}