diff options
Diffstat (limited to 'overlays/etesync-dav/etebase.nix')
-rw-r--r-- | overlays/etesync-dav/etebase.nix | 64 |
1 files changed, 0 insertions, 64 deletions
diff --git a/overlays/etesync-dav/etebase.nix b/overlays/etesync-dav/etebase.nix deleted file mode 100644 index 8711725c..00000000 --- a/overlays/etesync-dav/etebase.nix +++ /dev/null | |||
@@ -1,64 +0,0 @@ | |||
1 | { lib | ||
2 | , stdenv | ||
3 | , fetchFromGitHub | ||
4 | , python39 | ||
5 | , rustPlatform | ||
6 | , pkg-config | ||
7 | , rustfmt | ||
8 | , setuptools-rust | ||
9 | , openssl | ||
10 | , msgpack | ||
11 | }: | ||
12 | |||
13 | python39.pkgs.buildPythonPackage rec { | ||
14 | pname = "etebase"; | ||
15 | version = "0.31.6"; | ||
16 | |||
17 | src = fetchFromGitHub { | ||
18 | owner = "etesync"; | ||
19 | repo = "etebase-py"; | ||
20 | rev = "v${version}"; | ||
21 | hash = "sha256-T61nPW3wjBRjmJ81w59T1b/Kxrwwqvyj3gILE9OF/5Q="; | ||
22 | }; | ||
23 | |||
24 | cargoDeps = rustPlatform.fetchCargoTarball { | ||
25 | inherit src; | ||
26 | name = "${pname}-${version}"; | ||
27 | hash = "sha256-wrMNtcaLAsWBVeJbYbYo+Xmobl01lnUbR9NUqqUzUgU="; | ||
28 | }; | ||
29 | |||
30 | format = "pyproject"; | ||
31 | |||
32 | nativeBuildInputs = [ | ||
33 | pkg-config | ||
34 | rustfmt | ||
35 | setuptools-rust | ||
36 | ] ++ (with rustPlatform; [ | ||
37 | cargoSetupHook | ||
38 | rust.cargo | ||
39 | rust.rustc | ||
40 | ]); | ||
41 | |||
42 | buildInputs = [ openssl ]; | ||
43 | |||
44 | propagatedBuildInputs = [ | ||
45 | msgpack | ||
46 | ]; | ||
47 | |||
48 | postPatch = '' | ||
49 | # Use system OpenSSL, which gets security updates. | ||
50 | substituteInPlace Cargo.toml \ | ||
51 | --replace ', features = ["vendored"]' "" | ||
52 | ''; | ||
53 | |||
54 | pythonImportsCheck = [ "etebase" ]; | ||
55 | |||
56 | |||
57 | meta = with lib; { | ||
58 | broken = stdenv.isDarwin; | ||
59 | homepage = "https://www.etebase.com/"; | ||
60 | description = "A Python client library for Etebase"; | ||
61 | license = licenses.bsd3; | ||
62 | maintainers = with maintainers; [ _3699n thyol ]; | ||
63 | }; | ||
64 | } | ||