summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix24
1 files changed, 9 insertions, 15 deletions
diff --git a/odin.nix b/odin.nix
index 11a3c934..f92556de 100644
--- a/odin.nix
+++ b/odin.nix
@@ -78,22 +78,16 @@
78 services.uucp = { 78 services.uucp = {
79 enable = true; 79 enable = true;
80 nodeName = "odin"; 80 nodeName = "odin";
81 remoteNodes = [ "ymir" "hel" ]; 81 remoteNodes = {
82 sshUser = { 82 "ymir" = {
83 openssh.authorizedKeys.keys = [ ''restrict,command="${config.security.wrapperDir}/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKD8ycFGfVkBL9wjA5Kc33cl6Qt5K2505G/38oH8Cy/e uucp@hel'' 83 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGANj+LJ4CI6VrAgBRocKCGq74kZnwD1PdKr/gdlfVr1 uucp@ymir"];
84 ''restrict,command="${config.security.wrapperDir}/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIGANj+LJ4CI6VrAgBRocKCGq74kZnwD1PdKr/gdlfVr1 uucp@ymir'' 84 hostnames = ["ymir.yggdrasil.li" "ymir.niflheim.yggdrasil"];
85 ]; 85 };
86 "hel" = {
87 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKD8ycFGfVkBL9wjA5Kc33cl6Qt5K2505G/38oH8Cy/e uucp@hel"];
88 hostnames = ["hel.asgard.yggdrasil" "hel.midgard.yggdrasil"];
89 };
86 }; 90 };
87 sshConfig = ''
88 Host ymir
89 Hostname ymir.niflheim.yggdrasil
90 IdentityFile ~/.ssh/ymir
91 Host hel
92 Hostname hel.midgard.yggdrasil
93 IdentityFile ~/.ssh/hel
94 '';
95 commandPath = ["${pkgs.rmail}/bin"];
96 defaultCommands = ["rmail"];
97 91
98 media-server = { 92 media-server = {
99 enable = true; 93 enable = true;