diff options
Diffstat (limited to 'modules/uucp.nix')
-rw-r--r-- | modules/uucp.nix | 5 |
1 files changed, 5 insertions, 0 deletions
diff --git a/modules/uucp.nix b/modules/uucp.nix index 95b675a6..abca2acb 100644 --- a/modules/uucp.nix +++ b/modules/uucp.nix | |||
@@ -48,12 +48,14 @@ let | |||
48 | commands = mkOption { | 48 | commands = mkOption { |
49 | type = types.listOf types.str; | 49 | type = types.listOf types.str; |
50 | default = cfg.defaultCommands; | 50 | default = cfg.defaultCommands; |
51 | defaultText = literalExpression "config.services.uucp.defaultCommands"; | ||
51 | description = "Commands to allow for this remote"; | 52 | description = "Commands to allow for this remote"; |
52 | }; | 53 | }; |
53 | 54 | ||
54 | protocols = mkOption { | 55 | protocols = mkOption { |
55 | type = types.separatedString ""; | 56 | type = types.separatedString ""; |
56 | default = cfg.defaultProtocols; | 57 | default = cfg.defaultProtocols; |
58 | defaultText = literalExpression "config.services.uucp.defaultProtocols"; | ||
57 | description = "UUCP protocols to use for this remote"; | 59 | description = "UUCP protocols to use for this remote"; |
58 | }; | 60 | }; |
59 | 61 | ||
@@ -119,6 +121,7 @@ in { | |||
119 | commandPath = mkOption { | 121 | commandPath = mkOption { |
120 | type = types.listOf types.path; | 122 | type = types.listOf types.path; |
121 | default = [ "${pkgs.rmail}/bin" ]; | 123 | default = [ "${pkgs.rmail}/bin" ]; |
124 | defaultText = literalExpression ''[ "''${pkgs.rmail}/bin" ]''; | ||
122 | description = '' | 125 | description = '' |
123 | Command search path for all systems | 126 | Command search path for all systems |
124 | ''; | 127 | ''; |
@@ -151,6 +154,7 @@ in { | |||
151 | sshKeyDir = mkOption { | 154 | sshKeyDir = mkOption { |
152 | type = types.path; | 155 | type = types.path; |
153 | default = "${cfg.homeDir}/.ssh/"; | 156 | default = "${cfg.homeDir}/.ssh/"; |
157 | defaultText = literalExpression ''''${config.services.uucp.homeDir}/.ssh/''; | ||
154 | description = "Directory to store ssh keypairs"; | 158 | description = "Directory to store ssh keypairs"; |
155 | }; | 159 | }; |
156 | 160 | ||
@@ -202,6 +206,7 @@ in { | |||
202 | nmDispatch = mkOption { | 206 | nmDispatch = mkOption { |
203 | type = types.bool; | 207 | type = types.bool; |
204 | default = config.networking.networkmanager.enable; | 208 | default = config.networking.networkmanager.enable; |
209 | defaultText = literalExpression "config.networking.networkmanager.enable"; | ||
205 | description = '' | 210 | description = '' |
206 | Install a network-manager dispatcher script to automatically | 211 | Install a network-manager dispatcher script to automatically |
207 | call all remotes when networking is available | 212 | call all remotes when networking is available |