summaryrefslogtreecommitdiff
path: root/modules/pgbackrest.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pgbackrest.nix')
-rw-r--r--modules/pgbackrest.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/pgbackrest.nix b/modules/pgbackrest.nix
index ac0f9a35..cc865bca 100644
--- a/modules/pgbackrest.nix
+++ b/modules/pgbackrest.nix
@@ -172,6 +172,11 @@ in {
172 Group = cfg.tlsServer.group; 172 Group = cfg.tlsServer.group;
173 ExecStart = "${cfg.package}/bin/pgbackrest server"; 173 ExecStart = "${cfg.package}/bin/pgbackrest server";
174 ExecReload = "${pkgs.coreutils}/bin/kill -HUP $MAINPID"; 174 ExecReload = "${pkgs.coreutils}/bin/kill -HUP $MAINPID";
175
176 Environment = [
177 "LD_PRELOAD=${pkgs.libdscp}/lib/libdscp.so"
178 "DSCP=8"
179 ];
175 }; 180 };
176 }; 181 };
177 } // mapAttrs' (name: backupCfg: nameValuePair "pgbackrest-backup@${escapeSystemdPath name}" { 182 } // mapAttrs' (name: backupCfg: nameValuePair "pgbackrest-backup@${escapeSystemdPath name}" {
@@ -183,6 +188,11 @@ in {
183 Group = backupCfg.group; 188 Group = backupCfg.group;
184 Restart = "on-failure"; 189 Restart = "on-failure";
185 RestartSec = "5min"; 190 RestartSec = "5min";
191
192 Environment = [
193 "LD_PRELOAD=${pkgs.libdscp}/lib/libdscp.so"
194 "DSCP=8"
195 ];
186 }; 196 };
187 }) cfg.backups; 197 }) cfg.backups;
188 198