summaryrefslogtreecommitdiff
path: root/modules/pgbackrest.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/pgbackrest.nix')
-rw-r--r--modules/pgbackrest.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/modules/pgbackrest.nix b/modules/pgbackrest.nix
index ca319ccd..ac0f9a35 100644
--- a/modules/pgbackrest.nix
+++ b/modules/pgbackrest.nix
@@ -54,6 +54,7 @@ in {
54 stanza = mkOption { 54 stanza = mkOption {
55 type = types.str; 55 type = types.str;
56 default = config.networking.hostName; 56 default = config.networking.hostName;
57 defaultText = literalExpression "config.networking.hostName";
57 }; 58 };
58 }; 59 };
59 60
@@ -115,6 +116,7 @@ in {
115 stanza = mkOption { 116 stanza = mkOption {
116 type = types.str; 117 type = types.str;
117 default = cfg.configurePostgresql.stanza; 118 default = cfg.configurePostgresql.stanza;
119 defaultText = literalExpression "config.services.pgbackrest.configurePostgresql.stanza";
118 }; 120 };
119 repo = mkOption { 121 repo = mkOption {
120 type = types.nullOr (types.strMatching "^[0-9]+$"); 122 type = types.nullOr (types.strMatching "^[0-9]+$");