summaryrefslogtreecommitdiff
path: root/modules/openssh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/openssh.nix')
-rw-r--r--modules/openssh.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/modules/openssh.nix b/modules/openssh.nix
index b5950610..78749869 100644
--- a/modules/openssh.nix
+++ b/modules/openssh.nix
@@ -6,8 +6,8 @@ with lib;
6 options = { 6 options = {
7 services.openssh = { 7 services.openssh = {
8 settings.HostKeyAlgorithms = mkOption { 8 settings.HostKeyAlgorithms = mkOption {
9 type = types.listOf types.str; 9 type = types.str;
10 default = [ 10 default = concatStringsSep "," [
11 "ssh-ed25519" 11 "ssh-ed25519"
12 "ssh-ed25519-cert-v01@openssh.com" 12 "ssh-ed25519-cert-v01@openssh.com"
13 "sk-ssh-ed25519@openssh.com" 13 "sk-ssh-ed25519@openssh.com"
@@ -32,8 +32,8 @@ with lib;
32 ]; 32 ];
33 }; 33 };
34 settings.CASignatureAlgorithms = mkOption { 34 settings.CASignatureAlgorithms = mkOption {
35 type = types.listOf types.str; 35 type = types.str;
36 default = [ 36 default = concatStringsSep "," [
37 "ssh-ed25519" 37 "ssh-ed25519"
38 "ecdsa-sha2-nistp256" 38 "ecdsa-sha2-nistp256"
39 "ecdsa-sha2-nistp384" 39 "ecdsa-sha2-nistp384"
@@ -45,8 +45,8 @@ with lib;
45 ]; 45 ];
46 }; 46 };
47 settings.PubkeyAcceptedAlgorithms = mkOption { 47 settings.PubkeyAcceptedAlgorithms = mkOption {
48 type = types.listOf types.str; 48 type = types.str;
49 default = [ 49 default = concatStringsSep "," [
50 "ssh-ed25519" 50 "ssh-ed25519"
51 "ssh-ed25519-cert-v01@openssh.com" 51 "ssh-ed25519-cert-v01@openssh.com"
52 "sk-ssh-ed25519@openssh.com" 52 "sk-ssh-ed25519@openssh.com"