summaryrefslogtreecommitdiff
path: root/modules/networkd/systemd-lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/networkd/systemd-lib.nix')
-rw-r--r--modules/networkd/systemd-lib.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/modules/networkd/systemd-lib.nix b/modules/networkd/systemd-lib.nix
index 2dbf1503..c5b5b7cb 100644
--- a/modules/networkd/systemd-lib.nix
+++ b/modules/networkd/systemd-lib.nix
@@ -90,6 +90,10 @@ in rec {
90 optional (attr ? ${name} && !isInt attr.${name}) 90 optional (attr ? ${name} && !isInt attr.${name})
91 "Systemd ${group} field `${name}' is not an integer"; 91 "Systemd ${group} field `${name}' is not an integer";
92 92
93 assertMaxLength = name: max: group: attr:
94 optional (attr ? ${name} && stringLength attr.${name} > max)
95 "Systemd ${group} field `${name}' is too long (max of ${max})";
96
93 checkUnitConfig = group: checks: attrs: let 97 checkUnitConfig = group: checks: attrs: let
94 # We're applied at the top-level type (attrsOf unitOption), so the actual 98 # We're applied at the top-level type (attrsOf unitOption), so the actual
95 # unit options might contain attributes from mkOverride and mkIf that we need to 99 # unit options might contain attributes from mkOverride and mkIf that we need to