summaryrefslogtreecommitdiff
path: root/modules/build-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/build-client.nix')
-rw-r--r--modules/build-client.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/build-client.nix b/modules/build-client.nix
index cedfc2eb..3e171897 100644
--- a/modules/build-client.nix
+++ b/modules/build-client.nix
@@ -6,7 +6,7 @@ let
6 cfg = config.nix.buildServers; 6 cfg = config.nix.buildServers;
7 7
8 secretName = name: "nix-ssh-builder-${name}-private"; 8 secretName = name: "nix-ssh-builder-${name}-private";
9 hostName = host: "nix-ssh-builder-${host}"; 9 buildHostName = host: "nix-ssh-builder-${host}";
10in { 10in {
11 options = { 11 options = {
12 nix = { 12 nix = {
@@ -88,7 +88,7 @@ in {
88 88
89 config = mkIf (cfg != {}) { 89 config = mkIf (cfg != {}) {
90 programs.ssh.extraConfig = concatMapStringsSep "\n" ({ name, value }: '' 90 programs.ssh.extraConfig = concatMapStringsSep "\n" ({ name, value }: ''
91 Host ${hostName name} 91 Host ${buildHostName name}
92 User nix-ssh-builder 92 User nix-ssh-builder
93 HostName ${value.address} 93 HostName ${value.address}
94 IdentitiesOnly yes 94 IdentitiesOnly yes
@@ -104,6 +104,6 @@ in {
104 104
105 sops.secrets = mapAttrs' (name: hCfg: nameValuePair (secretName name) { sopsFile = ../system-profiles/build-server/clients + "/${hostName}/private"; format = "binary"; }) cfg; 105 sops.secrets = mapAttrs' (name: hCfg: nameValuePair (secretName name) { sopsFile = ../system-profiles/build-server/clients + "/${hostName}/private"; format = "binary"; }) cfg;
106 106
107 nix.buildMachines = mapAttrsToList (name: hCfg: { hostName = hostName name; inherit (hCfg) system systems maxJobs speedFactor mandatoryFeatures supportedFeatures; }) cfg; 107 nix.buildMachines = mapAttrsToList (name: hCfg: { hostName = buildHostName name; inherit (hCfg) system systems maxJobs speedFactor mandatoryFeatures supportedFeatures; }) cfg;
108 }; 108 };
109} 109}