summaryrefslogtreecommitdiff
path: root/modules/build-client.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/build-client.nix')
-rw-r--r--modules/build-client.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/modules/build-client.nix b/modules/build-client.nix
index 9924b751..6322e6c0 100644
--- a/modules/build-client.nix
+++ b/modules/build-client.nix
@@ -15,6 +15,7 @@ in {
15 options = { 15 options = {
16 address = mkOption { 16 address = mkOption {
17 type = types.str; 17 type = types.str;
18 description = "Address of buildserver";
18 }; 19 };
19 20
20 system = mkOption { 21 system = mkOption {
@@ -82,10 +83,11 @@ in {
82 }; 83 };
83 }); 84 });
84 default = {}; 85 default = {};
86 description = "Buildservers to use";
85 }; 87 };
86 }; 88 };
87 }; 89 };
88 90
89 config = mkIf (cfg != {}) { 91 config = mkIf (cfg != {}) {
90 programs.ssh.extraConfig = concatMapStringsSep "\n" ({ name, value }: '' 92 programs.ssh.extraConfig = concatMapStringsSep "\n" ({ name, value }: ''
91 Host ${buildHostName name} 93 Host ${buildHostName name}