summaryrefslogtreecommitdiff
path: root/modules/borgcopy/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'modules/borgcopy/pyproject.toml')
-rw-r--r--modules/borgcopy/pyproject.toml22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/borgcopy/pyproject.toml b/modules/borgcopy/pyproject.toml
new file mode 100644
index 00000000..f3401ed2
--- /dev/null
+++ b/modules/borgcopy/pyproject.toml
@@ -0,0 +1,22 @@
1[tool.poetry]
2name = "copy_borg"
3version = "0.0.0"
4authors = ["Gregor Kleen <gkleen@yggdrasil.li>"]
5description = ""
6
7[tool.poetry.scripts]
8copy_borg = "copy_borg.__main__:main"
9
10[tool.poetry.dependencies]
11python = ">=3.10.0,<3.12"
12humanize = "^4.6.0"
13tqdm = "^4.65.0"
14python-dateutil = "^2.8.2"
15xdg = "^6.0.0"
16python-unshare = "^0.2"
17pyprctl = "^0.1.3"
18halo = "^0.0.31"
19
20[build-system]
21requires = ["poetry-core>=1.0.0"]
22build-backend = "poetry.core.masonry.api" \ No newline at end of file