summaryrefslogtreecommitdiff
path: root/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'installer.nix')
-rw-r--r--installer.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/installer.nix b/installer.nix
index 64629674..3987e8ab 100644
--- a/installer.nix
+++ b/installer.nix
@@ -1 +1,17 @@
1{...}: {} 1{ flake, ... }: {
2 imports = with flake.nixosModules.systemProfiles; [
3 default-locale
4 ];
5
6 config = {
7 networking.firewall = {
8 enable = true;
9 allowedTCPPorts = [ 22 # ssh
10 ];
11 };
12
13 systemd.services."sshd".wantedBy = ["multi-user.target"];
14
15 services.qemuGuest.enable = true;
16 };
17}