summaryrefslogtreecommitdiff
path: root/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'installer.nix')
-rw-r--r--installer.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/installer.nix b/installer.nix
deleted file mode 100644
index 310105b8..00000000
--- a/installer.nix
+++ /dev/null
@@ -1,26 +0,0 @@
1{ flake, pkgs, ... }: {
2 imports = with flake.nixosModules.systemProfiles; [
3 default-locale zfs
4 ];
5
6 config = {
7 networking.wireless.enable = false;
8
9 networking.firewall = {
10 enable = true;
11 allowedTCPPorts = [ 22 # ssh
12 ];
13 allowedUDPPortRanges = [
14 { from = 60000; to = 61000; } # mosh
15 ];
16 };
17
18 systemd.services."sshd".wantedBy = ["multi-user.target"];
19
20 services.qemuGuest.enable = true;
21
22 environment.systemPackages = with pkgs; [
23 nvme-cli iotop mosh
24 ];
25 };
26}