summaryrefslogtreecommitdiff
path: root/hosts/vidhar/prometheus/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/prometheus/default.nix')
-rw-r--r--hosts/vidhar/prometheus/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/hosts/vidhar/prometheus/default.nix b/hosts/vidhar/prometheus/default.nix
index 8e5ff0ea..e6de6806 100644
--- a/hosts/vidhar/prometheus/default.nix
+++ b/hosts/vidhar/prometheus/default.nix
@@ -69,6 +69,7 @@ in {
69 "--systemd.collector.enable-ip-accounting" 69 "--systemd.collector.enable-ip-accounting"
70 ]; 70 ];
71 }; 71 };
72 lvm.enable = true;
72 blackbox = { 73 blackbox = {
73 enable = true; 74 enable = true;
74 configFile = pkgs.writeText "blackbox-config.yaml" (builtins.toJSON { 75 configFile = pkgs.writeText "blackbox-config.yaml" (builtins.toJSON {
@@ -104,6 +105,13 @@ in {
104 relabel_configs = relabelHosts; 105 relabel_configs = relabelHosts;
105 scrape_interval = "1s"; 106 scrape_interval = "1s";
106 } 107 }
108 { job_name = "lvm";
109 static_configs = [
110 { targets = ["localhost:${toString config.services.prometheus.exporters.lvm.port}"]; }
111 ];
112 relabel_configs = relabelHosts;
113 scrape_interval = "5s";
114 }
107 { job_name = "systemd"; 115 { job_name = "systemd";
108 static_configs = [ 116 static_configs = [
109 { targets = ["localhost:${toString config.services.prometheus.exporters.systemd.port}"]; } 117 { targets = ["localhost:${toString config.services.prometheus.exporters.systemd.port}"]; }