summaryrefslogtreecommitdiff
path: root/hosts/vidhar/prometheus/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/prometheus/default.nix')
-rw-r--r--hosts/vidhar/prometheus/default.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/hosts/vidhar/prometheus/default.nix b/hosts/vidhar/prometheus/default.nix
index 017097ad..e85d64fc 100644
--- a/hosts/vidhar/prometheus/default.nix
+++ b/hosts/vidhar/prometheus/default.nix
@@ -51,18 +51,21 @@ in {
51 { targets = ["localhost:${toString config.services.prometheus.port}"]; } 51 { targets = ["localhost:${toString config.services.prometheus.port}"]; }
52 ]; 52 ];
53 relabel_configs = relabelHosts; 53 relabel_configs = relabelHosts;
54 scrape_interval = "1s";
54 } 55 }
55 { job_name = "node"; 56 { job_name = "node";
56 static_configs = [ 57 static_configs = [
57 { targets = ["localhost:${toString config.services.prometheus.exporters.node.port}"]; } 58 { targets = ["localhost:${toString config.services.prometheus.exporters.node.port}"]; }
58 ]; 59 ];
59 relabel_configs = relabelHosts; 60 relabel_configs = relabelHosts;
61 scrape_interval = "1s";
60 } 62 }
61 { job_name = "smartctl"; 63 { job_name = "smartctl";
62 static_configs = [ 64 static_configs = [
63 { targets = ["localhost:${toString config.services.prometheus.exporters.smartctl.port}"]; } 65 { targets = ["localhost:${toString config.services.prometheus.exporters.smartctl.port}"]; }
64 ]; 66 ];
65 relabel_configs = relabelHosts; 67 relabel_configs = relabelHosts;
68 scrape_interval = "1s";
66 } 69 }
67 { job_name = "snmp"; 70 { job_name = "snmp";
68 static_configs = [ 71 static_configs = [
@@ -81,6 +84,7 @@ in {
81 target_label = "__address__"; 84 target_label = "__address__";
82 } 85 }
83 ]; 86 ];
87 scrape_interval = "15s";
84 } 88 }
85 { job_name = "zte"; 89 { job_name = "zte";
86 static_configs = [ 90 static_configs = [
@@ -91,24 +95,28 @@ in {
91 target_label = "instance"; 95 target_label = "instance";
92 } 96 }
93 ]; 97 ];
98 scrape_interval = "15s";
94 } 99 }
95 { job_name = "unbound"; 100 { job_name = "unbound";
96 static_configs = [ 101 static_configs = [
97 { targets = ["localhost:${toString config.services.prometheus.exporters.unbound.port}"]; } 102 { targets = ["localhost:${toString config.services.prometheus.exporters.unbound.port}"]; }
98 ]; 103 ];
99 relabel_configs = relabelHosts; 104 relabel_configs = relabelHosts;
105 scrape_interval = "1s";
100 } 106 }
101 { job_name = "wireguard"; 107 { job_name = "wireguard";
102 static_configs = [ 108 static_configs = [
103 { targets = ["localhost:${toString config.services.prometheus.exporters.wireguard.port}"]; } 109 { targets = ["localhost:${toString config.services.prometheus.exporters.wireguard.port}"]; }
104 ]; 110 ];
105 relabel_configs = relabelHosts; 111 relabel_configs = relabelHosts;
112 scrape_interval = "1s";
106 } 113 }
107 { job_name = "corerad"; 114 { job_name = "corerad";
108 static_configs = [ 115 static_configs = [
109 { targets = ["localhost:9430"]; } 116 { targets = ["localhost:9430"]; }
110 ]; 117 ];
111 relabel_configs = relabelHosts; 118 relabel_configs = relabelHosts;
119 scrape_interval = "1s";
112 } 120 }
113 ]; 121 ];
114 }; 122 };