summaryrefslogtreecommitdiff
path: root/hosts/vidhar/prometheus.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/prometheus.nix')
-rw-r--r--hosts/vidhar/prometheus.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/hosts/vidhar/prometheus.nix b/hosts/vidhar/prometheus.nix
index 1eaacd0f..2ad6667a 100644
--- a/hosts/vidhar/prometheus.nix
+++ b/hosts/vidhar/prometheus.nix
@@ -36,7 +36,7 @@ in {
36 snmp = { 36 snmp = {
37 enable = true; 37 enable = true;
38 configuration = { 38 configuration = {
39 default = { auth = { community = "public"; }; version = "2"; }; 39 default = { auth = { community = "public"; }; version = 2; };
40 }; 40 };
41 }; 41 };
42 unbound = { 42 unbound = {
@@ -101,8 +101,17 @@ in {
101 ]; 101 ];
102 relabel_configs = relabelHosts; 102 relabel_configs = relabelHosts;
103 } 103 }
104 { job_name = "corerad";
105 static_configs = [
106 { targets = ["localhost:9430"]; }
107 ];
108 relabel_configs = relabelHosts;
109 }
104 ]; 110 ];
105 }; 111 };
112 users.users.${config.services.prometheus.exporters.unbound.user} = {
113 extraGroups = [ config.services.unbound.group ];
114 };
106 115
107 systemd.services."prometheus-zte-exporter@10.141.1.3" = { 116 systemd.services."prometheus-zte-exporter@10.141.1.3" = {
108 wantedBy = [ "multi-user.target" ]; 117 wantedBy = [ "multi-user.target" ];
@@ -136,7 +145,7 @@ in {
136 145
137 Type = "simple"; 146 Type = "simple";
138 ExecStart = "${pkgs.zte-prometheus-exporter}/bin/zte-prometheus-exporter"; 147 ExecStart = "${pkgs.zte-prometheus-exporter}/bin/zte-prometheus-exporter";
139 Environment = "ZTE_BASEURL=%I ZTE_HOSTNAME=localhost ZTE_PORT=9900"; 148 Environment = "ZTE_BASEURL=http://%I ZTE_HOSTNAME=localhost ZTE_PORT=9900";
140 EnvironmentFile = config.sops.secrets."zte_10.141.1.3".path; 149 EnvironmentFile = config.sops.secrets."zte_10.141.1.3".path;
141 }; 150 };
142 }; 151 };