summaryrefslogtreecommitdiff
path: root/hosts/vidhar/network/dsl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/network/dsl.nix')
-rw-r--r--hosts/vidhar/network/dsl.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/hosts/vidhar/network/dsl.nix b/hosts/vidhar/network/dsl.nix
index aa2adf4b..2655b09a 100644
--- a/hosts/vidhar/network/dsl.nix
+++ b/hosts/vidhar/network/dsl.nix
@@ -66,16 +66,19 @@ in {
66 text = '' 66 text = ''
67 ethtool -K telekom tso off gso off gro off 67 ethtool -K telekom tso off gso off gro off
68 68
69 tc qdisc replace dev "${pppInterface}" root cake memlimit 64Mb pppoe-ptm nat diffserv4 wash bandwidth 35mbit
70
71 modprobe ifb 69 modprobe ifb
72 ip link del "ifb4${pppInterface}" || true 70 ip link del "ifb4${pppInterface}" || true
73 ip link add name "ifb4${pppInterface}" type ifb 71 ip link add name "ifb4${pppInterface}" type ifb
72 ip link set "ifb4${pppInterface}" up
73
74 tc qdisc del dev "ifb4${pppInterface}" root || true
74 tc qdisc del dev "${pppInterface}" ingress || true 75 tc qdisc del dev "${pppInterface}" ingress || true
76 tc qdisc del dev "${pppInterface}" root || true
77
75 tc qdisc add dev "${pppInterface}" handle ffff: ingress 78 tc qdisc add dev "${pppInterface}" handle ffff: ingress
79 tc filter add dev "${pppInterface}" parent ffff: basic action ctinfo dscp 0x0000003f 0x00000040 action mirred egress redirect dev "ifb4${pppInterface}"
76 tc qdisc replace dev "ifb4${pppInterface}" root cake memlimit 64Mb pppoe-ptm diffserv4 bandwidth 93mbit 80 tc qdisc replace dev "ifb4${pppInterface}" root cake memlimit 64Mb pppoe-ptm diffserv4 bandwidth 93mbit
77 ip link set "ifb4${pppInterface}" up 81 tc qdisc replace dev "${pppInterface}" root cake memlimit 64Mb pppoe-ptm nat diffserv4 wash bandwidth 35mbit
78 tc filter add dev "${pppInterface}" parent ffff: matchall action mirred egress redirect dev "ifb4${pppInterface}"
79 ''; 82 '';
80 }; 83 };
81 in "${app}/bin/${app.meta.mainProgram}"; 84 in "${app}/bin/${app.meta.mainProgram}";