summaryrefslogtreecommitdiff
path: root/hosts/vidhar/network/dsl.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/network/dsl.nix')
-rw-r--r--hosts/vidhar/network/dsl.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/hosts/vidhar/network/dsl.nix b/hosts/vidhar/network/dsl.nix
index 9c4e554c..064d4756 100644
--- a/hosts/vidhar/network/dsl.nix
+++ b/hosts/vidhar/network/dsl.nix
@@ -239,5 +239,16 @@ in {
239 group = "dhcpcd"; 239 group = "dhcpcd";
240 }; 240 };
241 users.groups.dhcpcd = {}; 241 users.groups.dhcpcd = {};
242
243 systemd.services.unbound = {
244 wantedBy = [ "dhcpcd-${pppInterface}.service" ];
245 bindsTo = [ "dhcpcd-${pppInterface}.service" ];
246 after = [ "dhcpcd-${pppInterface}.service" ];
247
248 serviceConfig = {
249 Restart = lib.mkForce "always";
250 RestartSec = "5";
251 };
252 };
242 }; 253 };
243} 254}