summaryrefslogtreecommitdiff
path: root/hosts/vidhar/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/default.nix')
-rw-r--r--hosts/vidhar/default.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/hosts/vidhar/default.nix b/hosts/vidhar/default.nix
index 3b47a1dc..3c7bccc5 100644
--- a/hosts/vidhar/default.nix
+++ b/hosts/vidhar/default.nix
@@ -1,4 +1,4 @@
1{ flake, pkgs, lib, ... }: 1{ hostName, flake, pkgs, lib, ... }:
2{ 2{
3 imports = with flake.nixosModules.systemProfiles; [ 3 imports = with flake.nixosModules.systemProfiles; [
4 openssh rebuild-machines initrd-all-crypto-modules 4 openssh rebuild-machines initrd-all-crypto-modules
@@ -26,7 +26,20 @@
26 initrd = { 26 initrd = {
27 supportedFilesystems = [ "zfs" ]; 27 supportedFilesystems = [ "zfs" ];
28 kernelModules = [ "dm_raid" ]; 28 kernelModules = [ "dm_raid" ];
29
30 luks.devices = {
31 nvm0.device = "/dev/disk/by-label/${hostName}-nvm0";
32 nvm1.device = "/dev/disk/by-label/${hostName}-nvm1";
33
34 hdd0.device = "/dev/disk/by-label/${hostName}-hdd0";
35 hdd1.device = "/dev/disk/by-label/${hostName}-hdd1";
36 hdd2.device = "/dev/disk/by-label/${hostName}-hdd2";
37 hdd3.device = "/dev/disk/by-label/${hostName}-hdd3";
38 hdd4.device = "/dev/disk/by-label/${hostName}-hdd4";
39 hdd5.device = "/dev/disk/by-label/${hostName}-hdd5";
40 };
29 }; 41 };
42
30 supportedFilesystems = [ "zfs" ]; 43 supportedFilesystems = [ "zfs" ];
31 zfs = { 44 zfs = {
32 enableUnstable = true; 45 enableUnstable = true;