diff options
Diffstat (limited to 'hosts/surtr/zfs.nix')
-rw-r--r-- | hosts/surtr/zfs.nix | 101 |
1 files changed, 101 insertions, 0 deletions
diff --git a/hosts/surtr/zfs.nix b/hosts/surtr/zfs.nix new file mode 100644 index 00000000..3cbd0cf0 --- /dev/null +++ b/hosts/surtr/zfs.nix | |||
@@ -0,0 +1,101 @@ | |||
1 | { pkgs, config, ... }: | ||
2 | let | ||
3 | snapshotNames = ["frequent" "hourly" "daily" "monthly" "yearly"]; | ||
4 | snapshotCount = { | ||
5 | frequent = 24; | ||
6 | hourly = 24; | ||
7 | daily = 30; | ||
8 | monthly = 12; | ||
9 | yearly = 5; | ||
10 | }; | ||
11 | snapshotTimerConfig = { | ||
12 | frequent = { OnCalendar = "*:0/5 UTC"; Persistent = true; }; | ||
13 | hourly = { OnCalendar = "hourly UTC"; Persistent = true; }; | ||
14 | daily = { OnCalendar = "daily UTC"; Persistent = true; }; | ||
15 | monthly = { OnCalendar = "monthly UTC"; Persistent = true; }; | ||
16 | yearly = { OnCalendar = "yearly UTC"; Persistent = true; }; | ||
17 | }; | ||
18 | snapshotDescr = { | ||
19 | frequent = "few minutes"; | ||
20 | hourly = "hour"; | ||
21 | daily = "day"; | ||
22 | monthly = "month"; | ||
23 | yearly = "year"; | ||
24 | }; | ||
25 | |||
26 | zfs = config.boot.zfs.package; | ||
27 | |||
28 | autosnapPackage = pkgs.zfstools.override { inherit zfs; }; | ||
29 | in { | ||
30 | config = { | ||
31 | fileSystems = { | ||
32 | "/nix" = | ||
33 | { device = "surtr/local/nix"; | ||
34 | fsType = "zfs"; | ||
35 | }; | ||
36 | |||
37 | "/root" = | ||
38 | { device = "surtr/safe/home-root"; | ||
39 | fsType = "zfs"; | ||
40 | neededForBoot = true; | ||
41 | }; | ||
42 | |||
43 | "/var/lib/systemd" = | ||
44 | { device = "surtr/local/var-lib-systemd"; | ||
45 | fsType = "zfs"; | ||
46 | neededForBoot = true; | ||
47 | }; | ||
48 | |||
49 | "/var/lib/nixos" = | ||
50 | { device = "surtr/local/var-lib-nixos"; | ||
51 | fsType = "zfs"; | ||
52 | neededForBoot = true; | ||
53 | }; | ||
54 | |||
55 | "/var/log" = | ||
56 | { device = "surtr/local/var-log"; | ||
57 | fsType = "zfs"; | ||
58 | }; | ||
59 | |||
60 | "/home" = | ||
61 | { device = "surtr/safe/home"; | ||
62 | fsType = "zfs"; | ||
63 | }; | ||
64 | }; | ||
65 | |||
66 | systemd.services = | ||
67 | let mkSnapService = snapName: { | ||
68 | name = "zfs-snapshot-${snapName}"; | ||
69 | value = { | ||
70 | description = "ZFS auto-snapshot every ${snapshotDescr.${snapName}}"; | ||
71 | after = [ "zfs-import.target" ]; | ||
72 | serviceConfig = { | ||
73 | Type = "oneshot"; | ||
74 | ExecStart = "${autosnapPackage}/bin/zfs-auto-snapshot -k -p -u ${snapName} ${toString snapshotCount.${snapName}}"; | ||
75 | }; | ||
76 | restartIfChanged = false; | ||
77 | |||
78 | preStart = '' | ||
79 | ${zfs}/bin/zfs set com.sun:auto-snapshot=true surtr/safe | ||
80 | ''; | ||
81 | }; | ||
82 | }; | ||
83 | in builtins.listToAttrs (map mkSnapService snapshotNames); | ||
84 | |||
85 | systemd.timers = | ||
86 | let mkSnapTimer = snapName: { | ||
87 | name = "zfs-snapshot-${snapName}"; | ||
88 | value = { | ||
89 | wantedBy = [ "timers.target" ]; | ||
90 | timerConfig = snapshotTimerConfig.${snapName}; | ||
91 | }; | ||
92 | }; | ||
93 | in builtins.listToAttrs (map mkSnapTimer snapshotNames); | ||
94 | |||
95 | services.zfs.trim.enable = false; | ||
96 | services.zfs.autoScrub = { | ||
97 | enable = true; | ||
98 | interval = "Sun *-*-1..7 04:00:00"; | ||
99 | }; | ||
100 | }; | ||
101 | } | ||