summaryrefslogtreecommitdiff
path: root/hosts/surtr/postgres.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/surtr/postgres.nix')
-rw-r--r--hosts/surtr/postgres.nix20
1 files changed, 0 insertions, 20 deletions
diff --git a/hosts/surtr/postgres.nix b/hosts/surtr/postgres.nix
deleted file mode 100644
index e8ea73be..00000000
--- a/hosts/surtr/postgres.nix
+++ /dev/null
@@ -1,20 +0,0 @@
1{ pkgs, ... }:
2{
3 config = {
4 services.postgresql = {
5 enable = true;
6 package = pkgs.postgresql_14;
7 ensureDatabases = [
8 "matrix-synapse"
9 ];
10 ensureUsers = [
11 { name = "matrix-synapse";
12 ensurePermissions = {
13 "DATABASE \"matrix-synapse\"" = "ALL PRIVILEGES";
14 "ALL TABLES IN SCHEMA public" = "ALL PRIVILEGES";
15 };
16 }
17 ];
18 };
19 };
20}