summaryrefslogtreecommitdiff
path: root/hosts/surtr/email/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/surtr/email/default.nix')
-rw-r--r--hosts/surtr/email/default.nix31
1 files changed, 11 insertions, 20 deletions
diff --git a/hosts/surtr/email/default.nix b/hosts/surtr/email/default.nix
index 390df5fd..9c3e8849 100644
--- a/hosts/surtr/email/default.nix
+++ b/hosts/surtr/email/default.nix
@@ -20,26 +20,17 @@ let
20 ''; 20 '';
21 }; 21 };
22 22
23 ccert-policy-server = flakeInputs.mach-nix.lib.${config.nixpkgs.system}.buildPythonPackage { 23 ccert-policy-server =
24 src = ./ccert-policy-server; 24 with pkgs.poetry2nix;
25 pname = "ccert-policy-server"; 25 mkPoetryApplication {
26 version = "0.0.0"; 26 projectDir = cleanPythonSources { src = ./ccert-policy-server; };
27 27
28 python = "python39"; 28 overrides = overrides.withDefaults (self: super: {
29 ignoreDataOutdated = true; 29 systemd-python = super.systemd-python.overridePythonAttrs (oldAttrs: {
30 30 buildInputs = (oldAttrs.buildInputs or []) ++ [ super.setuptools ];
31 requirements = '' 31 });
32 sdnotify 32 });
33 systemd-socketserver 33 };
34 psycopg >=3.0.0
35 psycopg-pool >=3.0.0
36 psycopg-binary >=3.0.0
37 '';
38
39 overridesPre = [
40 (self: super: { systemd-python = super.systemd.overrideAttrs (oldAttrs: { pname = "systemd-python"; }); })
41 ];
42 };
43 34
44 spmDomains = ["bouncy.email"]; 35 spmDomains = ["bouncy.email"];
45 emailDomains = spmDomains ++ ["kleen.consulting"]; 36 emailDomains = spmDomains ++ ["kleen.consulting"];