summaryrefslogtreecommitdiff
path: root/hosts/surtr/bifrost/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/surtr/bifrost/default.nix')
-rw-r--r--hosts/surtr/bifrost/default.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/hosts/surtr/bifrost/default.nix b/hosts/surtr/bifrost/default.nix
index bdedf5b6..ccf0c959 100644
--- a/hosts/surtr/bifrost/default.nix
+++ b/hosts/surtr/bifrost/default.nix
@@ -1,4 +1,4 @@
1{ config, lib, ... }: 1{ config, lib, pkgs, ... }:
2 2
3with lib; 3with lib;
4 4
@@ -56,5 +56,17 @@ in {
56 format = "binary"; 56 format = "binary";
57 sopsFile = ./surtr.priv; 57 sopsFile = ./surtr.priv;
58 }; 58 };
59
60 systemd.services."bifrost-dscp" = {
61 wantedBy = ["sys-subsystem-net-devices-bifrost.device"];
62 after = ["sys-subsystem-net-devices-bifrost.device"];
63 bindsTo = ["sys-subsystem-net-devices-bifrost.device"];
64
65 serviceConfig = {
66 Type = "oneshot";
67 ExecStart = "${pkgs.preserve-dscp}/bin/preserve-dscp bifrost ens3";
68 ExecStop = "${pkgs.preserve-dscp}/bin/preserve-dscp bifrost ens3 --unload";
69 };
70 };
59 }; 71 };
60} 72}