summaryrefslogtreecommitdiff
path: root/hel/hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hel/hw.nix')
-rw-r--r--hel/hw.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/hel/hw.nix b/hel/hw.nix
new file mode 100644
index 00000000..9c5126ad
--- /dev/null
+++ b/hel/hw.nix
@@ -0,0 +1,33 @@
1{ config, lib, pkgs, ... }:
2
3{
4 imports =
5 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
6 ];
7
8 boot.initrd.availableKernelModules = [ "xhci_pci" "nvme" "usb_storage" "sd_mod" "rtsx_pci_sdmmc" ];
9 boot.kernelModules = [ "kvm-intel" ];
10 boot.extraModulePackages = [ ];
11
12 fileSystems."/" =
13 { device = "/dev/disk/by-label/hel-btrfs";
14 fsType = "btrfs";
15 };
16
17 fileSystems."/boot" =
18 { device = "/dev/disk/by-uuid/3ADC-E1CD";
19 fsType = "vfat";
20 };
21
22 swapDevices =
23 [ { device = "/dev/disk/by-label/hel-swap"; }
24 ];
25
26 nix.maxJobs = lib.mkDefault 4;
27
28 hardware.trackpoint = {
29 enable = true;
30 emulateWheel = true;
31 sensitivity = 255;
32 };
33}