summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix11
1 files changed, 10 insertions, 1 deletions
diff --git a/hel.nix b/hel.nix
index c5dea9be..7d3758c8 100644
--- a/hel.nix
+++ b/hel.nix
@@ -47,8 +47,17 @@
47 shadow 47 shadow
48 (callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; }) 48 (callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; })
49 (callPackage ./utils/nix/rebuild-system.nix {}) 49 (callPackage ./utils/nix/rebuild-system.nix {})
50 rewacom
50 ]; 51 ];
51 52
53 nixpkgs.config.packageOverrides = pkgs: rec {
54 rewacom = pkgs.writeScriptBin "rewacom" ''
55 #!${pkgs.stdenv.shell}
56 modprobe -r wacom
57 modprobe wacom
58 '';
59 }
60
52 # nixpkgs.config.packageOverrides = pkgs: rec { 61 # nixpkgs.config.packageOverrides = pkgs: rec {
53 # libqmi = pkgs.stdenv.lib.overrideDerivation pkgs.libqmi (old: { 62 # libqmi = pkgs.stdenv.lib.overrideDerivation pkgs.libqmi (old: {
54 # src = pkgs.fetchgit { 63 # src = pkgs.fetchgit {
@@ -224,7 +233,7 @@
224 233
225 security = { 234 security = {
226 sudo.extraConfig = '' 235 sudo.extraConfig = ''
227 Cmnd_Alias SYSCTRL = /run/current-system/sw/sbin/shutdown, /run/current-system/sw/sbin/reboot, /run/current-system/sw/sbin/halt, /run/current-system/sw/bin/systemctl 236 Cmnd_Alias SYSCTRL = /run/current-system/sw/sbin/shutdown, /run/current-system/sw/sbin/reboot, /run/current-system/sw/sbin/halt, /run/current-system/sw/bin/systemctl, ${pkgs.rewacom}/bin/rewacom
228 %wheel ALL=(ALL) NOPASSWD: SYSCTRL 237 %wheel ALL=(ALL) NOPASSWD: SYSCTRL
229 ''; 238 '';
230 239