summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/hel.nix b/hel.nix
index 6e7c7723..376492ca 100644
--- a/hel.nix
+++ b/hel.nix
@@ -43,15 +43,17 @@
43 43
44 nixpkgs.config = { 44 nixpkgs.config = {
45 packageOverrides = super: let self = super.pkgs; in rec { 45 packageOverrides = super: let self = super.pkgs; in rec {
46 linuxPackages = super.linuxPackages // { 46 linuxPackages_latest = super.linuxPackages_latest // {
47 kernel = super.linuxPackages.kernel.override { 47 kernel = super.linuxPackages_latest.kernel.override {
48 kernelPatches = super.linux.kernelPatches ++ [ { patch = ./hel/wacom.patch; name = "wacom-fix"; } 48 kernelPatches = super.linux_latest.kernelPatches ++ [ { patch = ./hel/wacom.patch; name = "wacom-fix"; }
49 ]; 49 ];
50 }; 50 };
51 }; 51 };
52 }; 52 };
53 }; 53 };
54 54
55 boot.kernelPackages = pkgs.linuxPackages_latest;
56
55 environment.systemPackages = with pkgs; [ 57 environment.systemPackages = with pkgs; [
56 git 58 git
57 slock 59 slock