summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix9
1 files changed, 1 insertions, 8 deletions
diff --git a/hel.nix b/hel.nix
index 13d0c6e5..4255dcca 100644
--- a/hel.nix
+++ b/hel.nix
@@ -254,14 +254,7 @@
254 program = "notify-gkleen"; 254 program = "notify-gkleen";
255 setgid = true; 255 setgid = true;
256 setuid = true; 256 setuid = true;
257 source = pkgs.writeScript "notify-gkleen" '' 257 source = pkgs.callPackage ./custom/notify-user.nix { inherit (pkgs.haskellPackages) ghcWithPackages; };
258 #!${pkgs.zsh}/bin/zsh
259
260 trap "exit 0" EXIT
261
262 DBUS_ADDRESS=$(grep "DBUS_SESSION_BUS_ADDRESS=" /home/gkleen/.dbus/session-bus/${"*"} | cut -d "=" -f 2-)
263 exec env DBUS_SESSION_BUS_ADDRESS=''${DBUS_ADDRESS} ${pkgs.libnotify}/bin/notify-send $@
264 '';
265 } 258 }
266 ]; 259 ];
267 }; 260 };