diff options
Diffstat (limited to 'hel.nix')
-rw-r--r-- | hel.nix | 27 |
1 files changed, 26 insertions, 1 deletions
@@ -98,6 +98,26 @@ | |||
98 | ip4 = [ { address = "10.141.2.2"; prefixLength = 32; } ]; | 98 | ip4 = [ { address = "10.141.2.2"; prefixLength = 32; } ]; |
99 | }; | 99 | }; |
100 | }); | 100 | }); |
101 | uucp = { | ||
102 | enable = true; | ||
103 | nodeName = "hel"; | ||
104 | remoteNodes = ["isaac" "ymir"]; # legacy name for odin | ||
105 | sshUser = { | ||
106 | openssh.authorizedKeys.keys = [ ''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIEgtDHA7oDIaRwggGGznNaKZF68rFTziqefSCn1t9ZKe uucp@odin'' | ||
107 | '''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFH1QWdgoC03nzW5GBuCl2pqASHeIXIYtE9IInHdaKcO uucp@ymir'' | ||
108 | ]; | ||
109 | }; | ||
110 | sshConfig = '' | ||
111 | Host isaac | ||
112 | Hostname odin.asgard.yggdrasil | ||
113 | IdentityFile ~/.ssh/odin | ||
114 | Host ymir | ||
115 | Hostname ymir.niflheim.yggdrasil | ||
116 | IdentityFile ~/.ssh/ymir | ||
117 | ''; | ||
118 | commandPath = []; | ||
119 | defaultCommands = []; | ||
120 | }; | ||
101 | }; | 121 | }; |
102 | 122 | ||
103 | users = { | 123 | users = { |
@@ -105,7 +125,12 @@ | |||
105 | 125 | ||
106 | extraUsers.root = { inherit (import ./users/gkleen.nix) shell hashedPassword; }; | 126 | extraUsers.root = { inherit (import ./users/gkleen.nix) shell hashedPassword; }; |
107 | 127 | ||
108 | extraGroups = { network = {}; }; | 128 | extraGroups = { |
129 | network = {}; | ||
130 | media = { | ||
131 | members = [ "gkleen" "uucp" ]; | ||
132 | }; | ||
133 | }; | ||
109 | }; | 134 | }; |
110 | 135 | ||
111 | security = { | 136 | security = { |