summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/hel.nix b/hel.nix
index f2147c3f..2a1b9736 100644
--- a/hel.nix
+++ b/hel.nix
@@ -254,7 +254,15 @@
254 program = "notify-gkleen"; 254 program = "notify-gkleen";
255 setgid = true; 255 setgid = true;
256 setuid = true; 256 setuid = true;
257 source = pkgs.callPackage ./custom/notify-user.nix { inherit (pkgs.haskellPackages) ghcWithPackages; user = "gkleen"; }; 257 source = pkgs.lib.writeTextFile {
258 name = "notify-gkleen";
259 text = ''
260 #!${pkgs.zsh}/bin/zsh
261
262 DBUS_ADDRESS=`grep "DBUS_SESSION_BUS_ADDRESS=" /home/gkleen/.dbus/session-bus/${"*"}-0 | cut -d "=" -f 2-`
263 exec env DBUS_SESSION_BUS_ADDRESS='${DBUS_ADDRESS} ${pkgs.libnotify}/notify-send '${(qq)@}
264 '';
265 };
258 } 266 }
259 ]; 267 ];
260 }; 268 };