summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index d8684703..6d4f4217 100644
--- a/flake.nix
+++ b/flake.nix
@@ -22,9 +22,17 @@
22 ref = "master"; 22 ref = "master";
23 inputs.nixpkgs.follows = "nixpkgs"; 23 inputs.nixpkgs.follows = "nixpkgs";
24 }; 24 };
25
26 imm = {
27 type = "github";
28 owner = "k0ral";
29 repo = "imm";
30 ref = "master";
31 inputs.nixpkgs.follows = "nixpkgs";
32 };
25 }; 33 };
26 34
27 outputs = { self, nixpkgs, home-manager, sops-nix }@inputs: 35 outputs = { self, nixpkgs, home-manager, sops-nix, ... }@inputs:
28 let 36 let
29 inherit (builtins) attrNames attrValues elemAt toJSON isNull pathExists; 37 inherit (builtins) attrNames attrValues elemAt toJSON isNull pathExists;
30 inherit (nixpkgs) lib; 38 inherit (nixpkgs) lib;