diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 10 |
1 files changed, 7 insertions, 3 deletions
@@ -13,7 +13,10 @@ | |||
13 | owner = "nix-community"; | 13 | owner = "nix-community"; |
14 | repo = "home-manager"; | 14 | repo = "home-manager"; |
15 | ref = "master"; | 15 | ref = "master"; |
16 | inputs.nixpkgs.follows = "nixpkgs"; | 16 | inputs = { |
17 | flake-compat.follows = "flake-compat"; | ||
18 | nixpkgs.follows = "nixpkgs"; | ||
19 | }; | ||
17 | }; | 20 | }; |
18 | sops-nix = { | 21 | sops-nix = { |
19 | type = "github"; | 22 | type = "github"; |
@@ -138,8 +141,9 @@ | |||
138 | // outputs | 141 | // outputs |
139 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); | 142 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); |
140 | 143 | ||
141 | systemsSelector = "x86_64-linux"; | 144 | # systemsSelector = "x86_64-linux"; |
142 | systems = filter (system: !(isNull (builtins.match systemsSelector system))) nixpkgs.lib.systems.supported.hydra; | 145 | # systems = filter (system: !(isNull (builtins.match systemsSelector system))) nixpkgs.lib.systems.flakeExposed; |
146 | systems = nixpkgs.lib.systems.flakeExposed; | ||
143 | nixpkgsPackages = localSystem: (makeOverridable (import (nixpkgs.outPath + "/pkgs/top-level"))) { inherit localSystem; }; | 147 | nixpkgsPackages = localSystem: (makeOverridable (import (nixpkgs.outPath + "/pkgs/top-level"))) { inherit localSystem; }; |
144 | forAllSystems = f: mapAttrs f (genAttrs systems nixpkgsPackages); | 148 | forAllSystems = f: mapAttrs f (genAttrs systems nixpkgsPackages); |
145 | forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); | 149 | forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); |