diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 6 insertions, 1 deletions
@@ -44,7 +44,7 @@ | |||
44 | inherit (nixpkgs) lib; | 44 | inherit (nixpkgs) lib; |
45 | utils = import ./utils { inherit lib; }; | 45 | utils = import ./utils { inherit lib; }; |
46 | inherit (utils) nixImport overrideModule; | 46 | inherit (utils) nixImport overrideModule; |
47 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists; | 47 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep; |
48 | 48 | ||
49 | accountUserName = accountName: | 49 | accountUserName = accountName: |
50 | let | 50 | let |
@@ -210,6 +210,11 @@ | |||
210 | filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); | 210 | filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); |
211 | in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides)); | 211 | in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides)); |
212 | 212 | ||
213 | nixPath = forAllSystems (system: _: concatStringsSep ":" [ | ||
214 | "nixpkgs=${nixpkgs.legacyPackages.${system}.path}" | ||
215 | "nixpkgs-overlays=${self.overlays-path.${system}}" | ||
216 | ]); | ||
217 | |||
213 | checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib; | 218 | checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib; |
214 | }; | 219 | }; |
215 | } | 220 | } |