diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 9 insertions, 2 deletions
@@ -1,5 +1,7 @@ | |||
1 | { | 1 | let |
2 | description = "gkleen's machines"; | 2 | description = "GKleen's flakey nixos configuration"; |
3 | in { | ||
4 | inherit description; | ||
3 | 5 | ||
4 | inputs = { | 6 | inputs = { |
5 | nixpkgs = { | 7 | nixpkgs = { |
@@ -100,5 +102,10 @@ | |||
100 | apps = recursiveUpdate activateNixosConfigurations activateHomeManagerConfigurations; | 102 | apps = recursiveUpdate activateNixosConfigurations activateHomeManagerConfigurations; |
101 | 103 | ||
102 | devShell = forAllSystems (system: systemPkgs: import ./shell.nix { pkgs = self.legacyPackages.${system}; }); | 104 | devShell = forAllSystems (system: systemPkgs: import ./shell.nix { pkgs = self.legacyPackages.${system}; }); |
105 | |||
106 | defaultTemplate = { | ||
107 | path = ./.; | ||
108 | inherit description; | ||
109 | }; | ||
103 | }; | 110 | }; |
104 | } | 111 | } |