diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -66,6 +66,11 @@ | |||
66 | pypi-deps-db.follows = "pypi-deps-db"; | 66 | pypi-deps-db.follows = "pypi-deps-db"; |
67 | }; | 67 | }; |
68 | }; | 68 | }; |
69 | |||
70 | leapseconds = { | ||
71 | url = "https://www.ietf.org/timezones/data/leap-seconds.list"; | ||
72 | flake = false; | ||
73 | }; | ||
69 | }; | 74 | }; |
70 | 75 | ||
71 | outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: | 76 | outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: |
@@ -210,11 +215,7 @@ | |||
210 | 215 | ||
211 | apps = foldr recursiveUpdate {} [activateNixosConfigurations activateHomeManagerConfigurations]; | 216 | apps = foldr recursiveUpdate {} [activateNixosConfigurations activateHomeManagerConfigurations]; |
212 | 217 | ||
213 | devShells = forAllSystems (system: systemPkgs: { default = import ./shell.nix { | 218 | devShells = forAllSystems (system: systemPkgs: { default = import ./shell.nix ({ inherit system; } // inputs); }); |
214 | pkgs = self.legacyPackages.${system}; | ||
215 | deploy-rs = deploy-rs.packages.${system}.deploy-rs; | ||
216 | nvfetcher = nvfetcher.defaultPackage.${system}; | ||
217 | };}); | ||
218 | 219 | ||
219 | templates.default = { | 220 | templates.default = { |
220 | path = ./.; | 221 | path = ./.; |