diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 34 |
1 files changed, 22 insertions, 12 deletions
@@ -13,11 +13,9 @@ | |||
13 | inputs = { | 13 | inputs = { |
14 | nixpkgs = { | 14 | nixpkgs = { |
15 | type = "github"; | 15 | type = "github"; |
16 | # owner = "NixOS"; | 16 | owner = "NixOS"; |
17 | owner = "gkleen"; | ||
18 | repo = "nixpkgs"; | 17 | repo = "nixpkgs"; |
19 | # ref = "nixos-unstable"; | 18 | ref = "nixos-unstable"; |
20 | ref = "ppp-systemd"; | ||
21 | }; | 19 | }; |
22 | nixpkgs-pgbackrest = { | 20 | nixpkgs-pgbackrest = { |
23 | type = "github"; | 21 | type = "github"; |
@@ -29,7 +27,7 @@ | |||
29 | type = "github"; | 27 | type = "github"; |
30 | owner = "NixOS"; | 28 | owner = "NixOS"; |
31 | repo = "nixpkgs"; | 29 | repo = "nixpkgs"; |
32 | ref = "23.11"; | 30 | ref = "24.05"; |
33 | }; | 31 | }; |
34 | nixpkgs-eostre = { | 32 | nixpkgs-eostre = { |
35 | type = "github"; | 33 | type = "github"; |
@@ -144,7 +142,7 @@ | |||
144 | type = "gitlab"; | 142 | type = "gitlab"; |
145 | owner = "gkleen"; | 143 | owner = "gkleen"; |
146 | repo = "backup-utils"; | 144 | repo = "backup-utils"; |
147 | ref = "v0.1.2"; | 145 | ref = "v0.1.3"; |
148 | inputs = { | 146 | inputs = { |
149 | nixpkgs.follows = "nixpkgs"; | 147 | nixpkgs.follows = "nixpkgs"; |
150 | poetry2nix.follows = "poetry2nix"; | 148 | poetry2nix.follows = "poetry2nix"; |
@@ -160,6 +158,18 @@ | |||
160 | poetry2nix.follows = "poetry2nix"; | 158 | poetry2nix.follows = "poetry2nix"; |
161 | }; | 159 | }; |
162 | }; | 160 | }; |
161 | nixos-hardware = { | ||
162 | type = "github"; | ||
163 | owner = "NixOS"; | ||
164 | repo = "nixos-hardware"; | ||
165 | ref = "master"; | ||
166 | }; | ||
167 | impermanence = { | ||
168 | type = "github"; | ||
169 | owner = "nix-community"; | ||
170 | repo = "impermanence"; | ||
171 | ref = "master"; | ||
172 | }; | ||
163 | }; | 173 | }; |
164 | 174 | ||
165 | outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: | 175 | outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: |
@@ -252,12 +262,12 @@ | |||
252 | // outputs | 262 | // outputs |
253 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); | 263 | // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); |
254 | 264 | ||
255 | # systemsSelector = "x86_64-linux"; | 265 | systemsSelector = "x86_64-linux"; |
256 | # systems = filter (system: !(isNull (builtins.match systemsSelector system))) nixpkgs.lib.systems.flakeExposed; | 266 | systems = filter (system: !(isNull (builtins.match systemsSelector system))) nixpkgs.lib.systems.flakeExposed; |
257 | systems = | 267 | # systems = |
258 | let | 268 | # let |
259 | disallowedSystems = ["armv5tel-linux" "armv6l-linux"]; | 269 | # disallowedSystems = ["armv5tel-linux" "armv6l-linux"]; |
260 | in filter (system: !(elem system disallowedSystems)) nixpkgs.lib.systems.flakeExposed; | 270 | # in filter (system: !(elem system disallowedSystems)) nixpkgs.lib.systems.flakeExposed; |
261 | nixpkgsPackages = localSystem: (makeOverridable (import (nixpkgs.outPath + "/pkgs/top-level"))) { inherit localSystem; }; | 271 | nixpkgsPackages = localSystem: (makeOverridable (import (nixpkgs.outPath + "/pkgs/top-level"))) { inherit localSystem; }; |
262 | forAllSystems = f: mapAttrs f (genAttrs systems nixpkgsPackages); | 272 | forAllSystems = f: mapAttrs f (genAttrs systems nixpkgsPackages); |
263 | forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); | 273 | forAllUsers = genAttrs (unique (map accountUserName (attrNames self.nixosModules.accounts))); |