summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index e380463b..f1a2e434 100644
--- a/flake.nix
+++ b/flake.nix
@@ -210,11 +210,6 @@
210 filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); 210 filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs);
211 in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides)); 211 in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides));
212 212
213 nixPath = forAllSystems (system: _: concatStringsSep ":" [
214 "nixpkgs=${nixpkgs.legacyPackages.${system}.path}"
215 "nixpkgs-overlays=${self.overlays-path.${system}}"
216 ]);
217
218 checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib; 213 checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib;
219 }; 214 };
220} 215}