summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index a218d2fe..bf412444 100644
--- a/flake.nix
+++ b/flake.nix
@@ -36,6 +36,13 @@
36 ref = "master"; 36 ref = "master";
37 inputs.nixpkgs.follows = "nixpkgs"; 37 inputs.nixpkgs.follows = "nixpkgs";
38 }; 38 };
39 flake-compat = {
40 type = "github";
41 owner = "edolstra";
42 repo = "flake-compat";
43 ref = "master";
44 flake = false;
45 };
39 }; 46 };
40 47
41 outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: 48 outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs:
@@ -166,9 +173,6 @@
166 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); 173 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations));
167 174
168 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; 175 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths;
169 overlays-path = forAllSystems (system: systemPkgs: systemPkgs.writeText "overlays.nix" ''
170 map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)}))
171 '');
172 176
173 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages; 177 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages;
174 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages; 178 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages;