summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index c8c4c365..a218d2fe 100644
--- a/flake.nix
+++ b/flake.nix
@@ -166,9 +166,9 @@
166 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); 166 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations));
167 167
168 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; 168 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths;
169 overlays-path = forAllSystems (system: systemPkgs: toString (systemPkgs.writeText "overlays.nix" '' 169 overlays-path = forAllSystems (system: systemPkgs: systemPkgs.writeText "overlays.nix" ''
170 map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)})) 170 map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)}))
171 '')); 171 '');
172 172
173 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages; 173 packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages;
174 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages; 174 packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages;