diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -335,7 +335,7 @@ | |||
335 | nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; }; | 335 | nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; }; |
336 | 336 | ||
337 | homeModules = nixImport rec { dir = ./home-modules; }; | 337 | homeModules = nixImport rec { dir = ./home-modules; }; |
338 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; inherit (configuration) home-files; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); | 338 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" configuration) nixosConfig.config.home-manager.users) self.nixosConfigurations)); |
339 | 339 | ||
340 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; | 340 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; |
341 | 341 | ||