summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix18
1 files changed, 12 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index c6eaab47..816fd499 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,20 +4,20 @@
4 nixConfig = { 4 nixConfig = {
5 extra-substituters = [ 5 extra-substituters = [
6 "https://nix-community.cachix.org" 6 "https://nix-community.cachix.org"
7 "https://niri.cachix.org"
7 ]; 8 ];
8 extra-trusted-public-keys = [ 9 extra-trusted-public-keys = [
9 "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs=" 10 "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
11 "niri.cachix.org-1:Wv0OmO7PsuocRKzfDoJ3mulSl7Z6oezYhGhR+3W2964="
10 ]; 12 ];
11 }; 13 };
12 14
13 inputs = { 15 inputs = {
14 nixpkgs = { 16 nixpkgs = {
15 type = "github"; 17 type = "github";
16 # owner = "NixOS"; 18 owner = "NixOS";
17 repo = "nixpkgs"; 19 repo = "nixpkgs";
18 # ref = "nixos-unstable"; 20 ref = "nixos-unstable";
19 owner = "gkleen";
20 ref = "fix/matrix-synapse";
21 }; 21 };
22 nixpkgs-pgbackrest = { 22 nixpkgs-pgbackrest = {
23 type = "github"; 23 type = "github";
@@ -184,9 +184,15 @@
184 repo = "NixVirt"; 184 repo = "NixVirt";
185 inputs.nixpkgs.follows = "nixpkgs"; 185 inputs.nixpkgs.follows = "nixpkgs";
186 }; 186 };
187 niri-flake = {
188 type = "github";
189 owner = "sodiboo";
190 repo = "niri-flake";
191 ref = "main";
192 };
187 }; 193 };
188 194
189 outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, ... }@inputs: 195 outputs = { self, nixpkgs, home-manager, sops-nix, deploy-rs, nvfetcher, niri-flake, ... }@inputs:
190 let 196 let
191 inherit (builtins) attrNames attrValues elemAt toJSON isNull pathExists; 197 inherit (builtins) attrNames attrValues elemAt toJSON isNull pathExists;
192 inherit (nixpkgs) lib; 198 inherit (nixpkgs) lib;
@@ -324,7 +330,7 @@
324 nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; }; 330 nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; };
325 331
326 homeModules = nixImport rec { dir = ./home-modules; }; 332 homeModules = nixImport rec { dir = ./home-modules; };
327 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); 333 homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; inherit (configuration) home-files; }) nixosConfig.config.home-manager.users) self.nixosConfigurations));
328 334
329 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; 335 overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths;
330 336