diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -172,7 +172,7 @@ | |||
172 | type = "github"; | 172 | type = "github"; |
173 | owner = "gkleen"; | 173 | owner = "gkleen"; |
174 | repo = "Waybar"; | 174 | repo = "Waybar"; |
175 | ref = "feat/privacy-ignore"; | 175 | ref = "feat/niri-workspaces-hide"; |
176 | inputs = { | 176 | inputs = { |
177 | nixpkgs.follows = "nixpkgs"; | 177 | nixpkgs.follows = "nixpkgs"; |
178 | flake-compat.follows = "flake-compat"; | 178 | flake-compat.follows = "flake-compat"; |
@@ -191,7 +191,7 @@ | |||
191 | ref = "main"; | 191 | ref = "main"; |
192 | inputs = { | 192 | inputs = { |
193 | nixpkgs.follows = "nixpkgs"; | 193 | nixpkgs.follows = "nixpkgs"; |
194 | niri-unstable.url = "github:gkleen/niri"; | 194 | # niri-unstable.url = "github:gkleen/niri"; |
195 | }; | 195 | }; |
196 | }; | 196 | }; |
197 | }; | 197 | }; |
@@ -335,7 +335,7 @@ | |||
335 | nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; }; | 335 | nixosConfigurations = installerNixosConfigurations // nixImport rec { dir = ./hosts; _import = mkNixosConfiguration [] dir; }; |
336 | 336 | ||
337 | homeModules = nixImport rec { dir = ./home-modules; }; | 337 | homeModules = nixImport rec { dir = ./home-modules; }; |
338 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; inherit (configuration) home-files; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); | 338 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: nameValuePair "${username}@${hostname}") nixosConfig.config.home-manager.users) self.nixosConfigurations)); |
339 | 339 | ||
340 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; | 340 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; |
341 | 341 | ||