summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 816fd499..47c03f23 100644
--- a/flake.nix
+++ b/flake.nix
@@ -189,6 +189,10 @@
189 owner = "sodiboo"; 189 owner = "sodiboo";
190 repo = "niri-flake"; 190 repo = "niri-flake";
191 ref = "main"; 191 ref = "main";
192 inputs = {
193 nixpkgs.follows = "nixpkgs";
194 niri-unstable.url = "github:gkleen/niri";
195 };
192 }; 196 };
193 }; 197 };
194 198
@@ -275,9 +279,10 @@
275 mkAccountModule = dir: path: accountName: 279 mkAccountModule = dir: path: accountName:
276 let 280 let
277 userName = accountUserName accountName; 281 userName = accountUserName accountName;
282 hostName = accountHostName accountName;
278 in overrideModule 283 in overrideModule
279 (import (dir + "/${path}")) 284 (import (dir + "/${path}"))
280 (inputs: inputs // { inherit userName; }) 285 (inputs: inputs // { inherit userName hostName; })
281 (outputs: { _file = dir + "/${path}"; } 286 (outputs: { _file = dir + "/${path}"; }
282 // outputs 287 // outputs
283 // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); }); 288 // { imports = [self.nixosModules.users.${userName} or ({...}: { imports = defaultUserProfiles userName; })] ++ (outputs.imports or []); });