diff options
Diffstat (limited to 'customized/jack2.nix')
-rw-r--r-- | customized/jack2.nix | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/customized/jack2.nix b/customized/jack2.nix new file mode 100644 index 00000000..f4f8fcaf --- /dev/null +++ b/customized/jack2.nix | |||
@@ -0,0 +1,47 @@ | |||
1 | { stdenv, fetchurl, alsaLib, expat, libsamplerate | ||
2 | , libsndfile, makeWrapper, pkgconfig, python | ||
3 | , firewireSupport ? false, ffado ? null, bash }: | ||
4 | |||
5 | assert firewireSupport -> ffado != null; | ||
6 | |||
7 | stdenv.mkDerivation rec { | ||
8 | name = "jack2-${version}"; | ||
9 | version = "1.9.10"; | ||
10 | |||
11 | src = fetchurl { | ||
12 | urls = [ | ||
13 | https://github.com/jackaudio/jack2/archive/v1.9.10.tar.gz | ||
14 | ]; | ||
15 | sha256 = "03b0iiyk3ng3vh5s8gaqwn565vik7910p56mlbk512bw3dhbdwc8"; | ||
16 | }; | ||
17 | |||
18 | buildInputs = | ||
19 | [ alsaLib expat libsamplerate libsndfile makeWrapper | ||
20 | pkgconfig python | ||
21 | ] ++ (stdenv.lib.optional firewireSupport ffado); | ||
22 | |||
23 | patchPhase = '' | ||
24 | substituteInPlace svnversion_regenerate.sh --replace /bin/bash ${bash}/bin/bash | ||
25 | ''; | ||
26 | |||
27 | configurePhase = '' | ||
28 | python waf configure --prefix=$out --alsa ${if firewireSupport then "--firewire" else ""} | ||
29 | ''; | ||
30 | |||
31 | buildPhase = "python waf build"; | ||
32 | |||
33 | installPhase = '' | ||
34 | python waf install | ||
35 | wrapProgram $out/bin/jack_control --set PYTHONPATH $PYTHONPATH | ||
36 | for bin in $out/bin/*; do | ||
37 | wrapProgram $bin --set JACK_PROMISCOUS_SERVER 1 | ||
38 | done | ||
39 | ''; | ||
40 | |||
41 | meta = with stdenv.lib; { | ||
42 | description = "JACK audio connection kit, version 2 with jackdbus"; | ||
43 | homepage = "http://jackaudio.org"; | ||
44 | license = licenses.gpl2Plus; | ||
45 | platforms = platforms.linux; | ||
46 | }; | ||
47 | } | ||